Dividing ( 多重双肩包)

Dividing ( 多重背包)

Dividing

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 20000/10000K (Java/Other)
Total Submission(s) : 9   Accepted Submission(s) : 5
Problem Description
Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value. Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.
 

Input
Each line in the input file describes one collection of marbles to be divided. The lines contain six non-negative integers n1 , . . . , n6 , where ni is the number of marbles of value i. So, the example from above would be described by the input-line "1 0 1 2 0 0". The maximum total number of marbles will be 20000. 
The last line of the input file will be "0 0 0 0 0 0"; do not process this line.
 

Output
For each collection, output "Collection #k:", where k is the number of the test case, and then either "Can be divided." or "Can't be divided.". 
Output a blank line after each test case.
 

Sample Input
1 0 1 2 0 0 1 0 0 0 1 1 0 0 0 0 0 0
 

Sample Output
Collection #1: Can't be divided. Collection #2: Can be divided.
 
题目大意:6种价值的物品的数量,问能否均分这些物品,使两人得到的价值相等(不能切割)。

代码如下:

#include <iostream>
#include <cstdio>
using namespace std;
int value[6] = {1 ,2 , 3 , 4 , 5 , 6};
int acount[6];
int m ;
int cases = 1;
int dist[200010];

void ZeroOnePack(int v)
{
    for(int i = m; i >= v; i --)
    {
        dist[i] = max(dist[i] , dist[i-v] + v);
    }
}

void CompletePack(int v)
{
    for(int i = v; i <= m; i ++)
        dist[i] = max(dist[i] , dist[i-v]+v);
}

void MultiPack(int v, int amount)
{
    if(v*amount >= m)
    {
        CompletePack(v);
    }
    else
    {
        int k = 1;
        int cnt = amount ;
        while(k <= cnt)
        {
            ZeroOnePack(k*v);
            cnt -= k ;
            k *= 2;
        }
        ZeroOnePack(cnt*v);
    }
}
int main()
{
    while(1)
    {
        int flag = 0;
        int sum = 0;
        //v = 0;
        for(int i = 0; i < 6; i ++)
        {
            scanf("%d",&acount[i]);
            if(acount[i]!= 0)
            {
                flag = 1;
            }
            sum += acount[i]*value[i];
        }
        if(!flag)break;
        m = sum / 2;
        printf("Collection #%d:\n",cases++);
        if(m*2 != sum){
            printf("Can't be divided.\n\n");
            //cout << "here"<<endl;
            continue;
        }
        for(int i = 0; i <= m; i ++)
        {
            dist[i] = 0;
        }
        for(int i = 0; i < 6; i ++)
        {
            MultiPack(value[i] , acount[i]);
        }
        if(dist[m] == m) printf("Can be divided.\n\n");
        else
            printf("Can't be divided.\n\n");
    }
    return 0;
}