UVa 10168 Summation of Four Primes(数论-哥德巴赫猜测)

UVa 10168 Summation of Four Primes(数论-哥德巴赫猜想)

Summation of Four Primes

Input: standard input

Output: standard output

Time Limit: 4 seconds

 

Euler proved in one of his classic theorems that prime numbers are infinite in number. But can every number be expressed as a summation of four positive primes? I don’t know the answer. May be you can help!!! I want your solution to be very efficient as I have a 386 machine at home. But the time limit specified above is for a Pentium III 800 machine. The definition of prime number for this problem is “A prime number is a positive number which has exactly two distinct integer factors”. As for example 37 is prime as it has exactly two distinct integer factors 37 and 1.

 

Input

The input contains one integer number N (N<=10000000) in every line. This is the number you will have to express as a summation of four primes. Input is terminated by end of file.

 

Output

For each line of input there is one line of output, which contains four prime numbers according to the given condition. If the number cannot be expressed as a summation of four prime numbers print the line “Impossible.” in a single line. There can be multiple solutions. Any good solution will be accepted.

 

Sample Input:

24
36
46

 

Sample Output:

3 11 3 7
3 7 13 13
11 11 17 7


Shahriar Manzoor


题目大意:

给定一个数n,问能用4个质因素相加表示,输出任意一种方案。


解题思路:这题比较有趣

(1)如果 n < 8,明显无解,最小的质数为2。

(2)如果 n >= 8,我们认为肯定有答案。

根据哥德巴赫猜想,一个偶数可以用两个质数相加表示。

1. 若n为奇数,可以 用 2+3+偶数 表示,偶数可以拆为两个质数,枚举其中一个,判断剩下的是不是质数即可。

2. 若n为偶数,可以 用 2+2+偶数 表示,方法同上。


参考代码:

#include <iostream>
#include <cstring>
using namespace std;

const int MAXN = 10000010;
int prime[MAXN], tot, n;
bool isPrime[MAXN];

void getPrime(int n) {
    memset(isPrime, true, sizeof(isPrime));
    for (int i = 2; i <= n; i++) {
        if (isPrime[i]) {
            tot++;
            prime[tot] = i;
        }
        for (int j = 1; j <= tot && i*prime[j] <= n; j++) {
            isPrime[i*prime[j]] = false;
            if (i % prime[j] == 0) break;
        }
    }
}

void solve() {
    if (n < 8) {
        cout << "Impossible." << endl;
    } else {
        if (n & 1) {
            cout << "2 3";
            for (int i = 0; i <= tot; i++) {
                int rest = n - 2 - 3 - prime[i];
                if (isPrime[rest]) {
                    cout << " " << prime[i] << " " << rest << endl;
                    break;
                }
            }
        } else {
            cout << "2 2";
            for (int i = 0; i <= tot; i++) {
                int rest = n - 2 - 2 - prime[i];
                if (isPrime[rest]) {
                    cout << " " << prime[i] << " " << rest << endl;
                    break;
                }
            }
        }
    }
}

int main() {
    ios::sync_with_stdio(false);
    getPrime(10000000);
    while (cin >> n) {
        solve();
    }
    return 0;
}