hdu1796 How many integers can you find-容斥原理

hdu1796 How many integers can you find----容斥原理

How many integers can you find

Time Limit: 12000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2286    Accepted Submission(s): 629


Problem Description
  Now you get a number N, and a M-integers set, you should find out how many integers which are small than N, that they can divided exactly by any integers in the set. For example, N=12, and M-integer set is {2,3}, so there is another set {2,3,4,6,8,9,10}, all the integers of the set can be divided exactly by 2 or 3. As a result, you just output the number 7.

Input
  There are a lot of cases. For each case, the first line contains two integers N and M. The follow line contains the M integers, and all of them are different from each other. 0<N<2^31,0<M<=10, and the M integer are non-negative and won’t exceed 20.

Output
  For each case, output the number.

Sample Input
12 2 2 3

Sample Output
7

Author
wangye

Source
2008 “Insigma International Cup” Zhejiang Collegiate Programming Contest - Warm Up(4)

Recommend
wangye
题意:给你一个数n和一个包含m个数的集合,让你求小于n的有多少个数能整除这m个数中的任意一个。
典型的容斥原理题。
#include<iostream>
#include<cstdlib>
#include<stdio.h>
#define ll __int64
using namespace std;
int a[15];
ll res,n;
int m;
int gcd(int x,int y)
{
    if(y==0) return x;
    return gcd(y,x%y);
}
int lcm(int x,int y)
{
    return x/gcd(x,y)*y;
}
void dfs(int now,int step,int k)
{
    if(step==m+1) return ;
    for(int i=step;i<=m;i++)
    {
        if(a[i]!=0)
        {
        int temp=lcm(now,a[i]);//应该是最小公倍数,而不是乘积,一开始nc了~
        int ans=n/temp;
        if(n%temp==0) ans--;
        if(k%2) res+=ans;
        else res-=ans;
        dfs(temp,i+1,k+1);
        }
    }
}
int main()
{
    while(scanf("%I64d%d",&n,&m)!=EOF)
    {
        res=0;
        for(int i=1;i<=m;i++)
        {
            scanf("%d",&a[i]);
            if(a[i]!=0)
            {
            int num=n/a[i];
            if(n%a[i]==0) num--;
            res+=num;
            }
        }
        for(int i=1;i<=m;i++)
        {
            if(a[i]!=0)
            dfs(a[i],i+1,0);
        }
        printf("%I64d\n",res);
    }
}